Firefox 3.5.5 Rated 3 out of 5 stars

Firefox could not install the file...
because: Not a valid install package-207

I tried everything I could find about this error but I just couldn't get it to install.

This review is for a previous version of the add-on (2.0.3).