FF 3.6RC1 Rated 3 out of 5 stars

Doesn't work with FF3.6RC1. Any ideas?

This review is for a previous version of the add-on (1.0.6). 

use newer version

You can get a newer version at http://newsfox.mozdev.org/installation.html#next or at AMO in the sandbox(not sure how to see the sandbox at AMO). Or you can complain to the management at AMO as they've had the newer version since November 11, 2009, unless I don't understand how to submit a new version with their new system.