FF3 compatibility Rated 2 out of 5 stars

General note to people interested in using this add-on with FF3 - it is NOT made compatible with the typical workaround methods (editing the install.rdf, nightly tester tools, turning off compatibility checking). While the extension installs, it makes the tab on the end icon-only (no title) and effectively serves no purpose. Wait for a compatible update - which I hope is forthcoming (double clicking when you\'ve got a bunch of tabs open already is a real annoyance!). Tested on FF3b4