Rated 3 out of 5 stars

Could you make it compatible with Firefox 3.6, please? Tnks.