Rated 1 out of 5 stars

There is a new version of this plug-in which is compatible with FF3. https://addons.mozilla.org/en-US/firefox/addon/9706