Net Usage Item Version History

20 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 2.0.3 455.2 KiB Works with Firefox 38.0a1 and later

Enabled addon for private browsing allowing users with 'Never remember history' setting to use the addon.
Usage history tab enhancements

Version 2.0.2 452.5 KiB Works with Firefox 38.0a1 and later

Fixed Bigpond parsing errors.
Brand new user interface developed on the new Firefox extension platform.

Version 1.2.390.1 105.1 KiB Works with Firefox 3.0 and later, SeaMonkey 2.0 and later

Lots of ISP bug fixes. Bringing in line with website version.

Version 1.2.337.1.1-signed 96.0 KiB Works with Firefox 3.0 and later, SeaMonkey 2.0 - 2.1b3

Version 1.2.310.1-signed 90.0 KiB Works with Firefox 3.0 and later, SeaMonkey 2.0 - 2.1b3

Version 1.2.225.1 82.0 KiB Works with Firefox 1.5 - 3.5.*, SeaMonkey 2.0a3pre - 2.0b1

Version 1.2.211 81.0 KiB Works with Firefox 1.5 - 3.0.*

Fix a bunch of ISPs like internode, bigpond

Version 1.2.206.1 81.0 KiB Works with Firefox 1.5 - 3.0.*

Version 1.2.199 77.0 KiB Works with Firefox 1.5 - 3.0.*

Firefox 3 Compatibility
Fixed unwired

Version 1.2.171 68.0 KiB Works with Firefox 1.5 - 2.0.0.*

Fixed Bigpond, Optus

Version 1.2.165 68.0 KiB Works with Firefox 1.5 - 2.0.0.*

Bug fixes

Version 1.2.138 65.0 KiB Works with Firefox 1.5 - 2.0.0.*

Fixed many bugs
Added multiple usage bars
GUI text now customisable

Version 1.1.90.1 64.0 KiB Works with Firefox 1.5 - 2.0.0.*

Version 1.0.9 59.0 KiB Works with Firefox 1.5 - 2.0.0.*

Version 1.0.3 56.0 KiB Works with Firefox 1.5 - 2.0.0.*

Complete rewrite.

Version 0.8.0 50.0 KiB Works with Firefox 0.9 - 1.0.7

Added WestNet, .netcall
Fixed optus, aanet

Version 0.7.3 56.0 KiB Works with Firefox 0.9 - 1.0.4

Fixed Netspace
Fixed for Deer Park

Version 0.7.1 56.0 KiB Works with Firefox 0.9 - 1.0.4

Version 0.6.8 55.0 KiB Works with Firefox 0.9 - 1.0.3

Version 0.5.8 47.0 KiB Works with Firefox 0.7 - 0.10