Compatibility Problems Rated 4 out of 5 stars

The firefox browser extension is not compatible with Firefox 3.0.6 and neither is the bookmarklet. However the Greasemonkey script metioned in an earlier review (thanks for this) makes the creation of notes work OK. Everyone who has problems should really try this, it is not difficult to install. Four stars for now, five when the extension is made compatible.