Rated 1 out of 5 stars

3.x should include 3.5. Wasn't 3.5 support supposed to come back way back in June?

This review is for a previous version of the add-on (0.8.6ff3).