Rated 5 out of 5 stars

@austerus, I can use with Firefox 6.0.2 (the latest version).
Check here for the latest version
https://bitbucket.org/satyr/ubiquity/downloads (tip.xpi)
https://ubiquity.mozilla.com/hg/ubiquity-firefox/

This user has 2 previous reviews of this add-on.