FYI... Rated 5 out of 5 stars

MinimizeToTray is compatible with Firefox all the way up to version 3.5.5. After that, it just doesn't work at all.