Awesome, but needs FF3 update! Rated 5 out of 5 stars

In case I haven't already mentioned it -- *awesome* theme, but it *NEEDS* an update for Firefox 3. I can only use Classic Compact for so long!

Please?

With a cheery on top?

:-D

-- J.P.