Seems to work with FF3! Rated 5 out of 5 stars

Is this a new release that now works with FF3? I'm not sure,but I tried to install it,and it worked! Fantastic,I've got my MWB back!!

This review is for a previous version of the add-on (0.2.9).