Rated 1 out of 5 stars

Junk. v1.2.2 still does not work with FF4. C'mon MS...

This review is for a previous version of the add-on (1.2.2).