Fraudulent Security Update Rated 1 out of 5 stars

This add-on is known to cause instability as well as creating a potential security risk. This is a well-rounded example of how extensions such as this, labeling as an "important security update", would eventually yield as fraud. If you are concerned for your browser's security, it is highly imperative not to install this add-on for the sake of your safety.

This review is for a previous version of the add-on (1.2.1).