Rated 5 out of 5 stars

Still works in FF22! Please update the install.rdf? :)

This review is for a previous version of the add-on (2.6). 

I've updated the compatibility on AMO...Firefox should allow you to install from there with no problem.