Rated 5 out of 5 stars

Could you please update the install.rdf to state that Menu Editor works with Firefox >= 22, since that's the case?