tengo un problema! Rated 5 out of 5 stars

no puedo instalar la barra de megaupload porque no tengo el firefox viejo para eso me sale un mensaje como este: Este complemento es para versiones antiguas de Firefox.
ademas si le doy a:Ignorar la comprobación no lo puedoinstalar me puedes dar la version de firefox para eso o algo para que lo pueda instalar