Firefox3.6 Rated 5 out of 5 stars

Can you do for Fire fox 3.6 !!! Please.
Perfavore puoi farlo per firefox3.6 se no non è compatibile!

This review is for a previous version of the add-on (1.0.1).