Still compatibile. Rated 4 out of 5 stars

after installing 10.0.2 on my FF 3.6.27. it stopped working but I tried rabusta patch it does work even with 10.0.2 and 11 (beta),
Anyone know how to change this information it is not compatibile?

This user has a previous review of this add-on.