SHAME! Does NOT work on Snow Leopard! Rated 1 out of 5 stars

Works great on WIndows 7 + firefox 4, does not on Snow Leopard with Firefox4.

This review is for a previous version of the add-on (0.9.3).