Rated 5 out of 5 stars

will this be upgraded to ff4 ?

This review is for a previous version of the add-on (1.2.0). 

The current version (1.2.8) supports up to Firefox 12.