Rated 2 out of 5 stars

When I try to install, it tells it isn't compatible with FF 3.5.2, though it's told on this page it works with FF 3.0 - 3.5.*, which includes 3.5.2, of course :(

This review is for a previous version of the add-on (1.0d).