Statusbar icon for FF 3.6 Rated 3 out of 5 stars

I think this is not a good practice..
Since the developer claims that v0.4.8 is compatible with FF versions 1.0 to 4.0, then should be full
compatible to these FF versions, not partially to some of them. Otherwise, should maintain two
MeasureIt versions, as other developers do.
If i keep v0.4.7 to FF3.6, then how i will be benefited from any enhancements or new features
in future versions, unrelated to statusbar icon..????

This review is for a previous version of the add-on (0.4.8).  This user has a previous review of this add-on.