Massive Extender Version History

9 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 1.2.1 26.6 KB Works with Firefox 5.0 and later, Thunderbird 5.0 and later

- Fixed bug that would prevent the add-on from initializing immediately after Firefox upgrade.
- Fixed bug that could prevent custom toolbars from initializing properly in Firefox toolbox.

NB: Not compatible with Firefox 17 and later.

Version 1.2 26.6 KB Works with Firefox 5.0 and later, Thunderbird 5.0 and later

- Workaround for Firefox 12 crash bug 722101.
- Compatible with Thunderbird (kind of experimental).

Version 1.1.2 25.6 KB Works with Firefox 4.0 and later

Summary of changes:
- Resolves compatibility with Firefox 5.
- Resolves performance-related bugs that could prevent the addon from properly initializing upon application startup and/or under heavy stress, requiring a re-enable cycle to bring it back to life.
- Fixes a terminal bug in v.1.1 which is now pulled off after passing only limited qualification at AMO.
- Resolves compatibility with the upcoming Add-on Collector update (2.0.2). This includes removal of the add-on compatibility check functionality which will be resolved in Add-on Collector.

Version 1.0 20.5 KB Works with Firefox 4.0 and later

This is a completely new version targeting specifically Firefox 4. Reduced functionality and new user interface.

Major changes compared to version 0.9.7 for Firefox 3.6:
- Massive Extender actions can now be accessed using a button on the standard Collector toolbar (or, alternatively, by right-clicking and collection header). There is no more separate toolbar.
- Massive Extender now supports 3 operations: launching installation of all add-ons from a collection, sorting add-ons by name and checking add-on compatibility data.
- Does not require restart after installation and updates.

Version 0.9.7 49.2 KB Works with Firefox 3.6 - 3.6.*, SeaMonkey 2.0 - 2.0.*, Thunderbird 3.0 - 3.1.*

Compatibility update for Firefox 3.6 + Add-on Collector 2.0.

Version 0.9.6 48.1 KB Works with Firefox 3.5 - 3.7a5pre, SeaMonkey 2.0 - 2.0.*, Thunderbird 3.0 - 3.1.*

Compatibility update to get along with:
* Mozilla Add-on Collector 1.2.1
* Mozilla Thunderbird 3.1+

Version 0.9.5 49.2 KB Works with Firefox 3.5 - 3.7a5pre, SeaMonkey 2.0 - 2.0.*, Thunderbird 3.0 - 3.0.*

Version 0.9.4 49.2 KB Works with Firefox 3.5 - 3.7a5pre, SeaMonkey 2.0 - 2.0.*, Thunderbird 3.0 - 3.0.*

RESOLVED:
* Compatibility with Thunderbird and SeaMonkey.
* Compatibility with Firefox 3.5.
CHANGED:
* Alphabetic sort of add-ons introduced in v.0.9.3 no longer places add-ons freshly added to the collection on top of the list.
KNOWN ISSUES:
* Incomplete or missing compatibility with Mac OSX (possibly in advanced mode only).
* Support for Firefox 3.7a5pre only available for the nightlies with the 'classic' Extension Manager (pre April 30, 2010).

Previous version v.0.9.3, not available publicly anymore, also introduced these changes/fixes:
NEW:
* Right-clicking on a collection header (name and description area above add-on list) now produces a menu allowing to sort add-ons by name instead of by date of addition.
RESOLVED:
* Compatibility with Firefox 3.7a5pre.
FIXED:
* Very minor random bugs (unreported).

Version 0.9.2 47.1 KB Works with Firefox 3.0 - 3.7a4pre, SeaMonkey 2.0 - 2.0.*, Thunderbird 3.0 - 3.0.*

- Resolved: compatibility with Add-on Collector 1.1.1
- Resolved: compatibility with SeaMonkey 2.0.*
- Added: improved bulk selection speed by packing multiple sqlite writes in transactions
- Fixed: several tiny javascript bugs
- Fixed: removed Thumbs.db files that sneaked into previous version's install package