A newer version for FF 4 is available Rated 4 out of 5 stars

Note: the version linked to at the top of this page is 0.81, and does *not* work in FF 4.0. There is an 0.82 release that *does* work, but you need to use Show All Versions to see it.

Or, you can use a direct link: :-)

The other comparable addon is EPUBReader. IT works well, but Lucifox gets the nod here because it lets you not have an ePub catalog, and specify where it is located if you do.

This review is for a previous version of the add-on (