It will no longer work you cant get add-ons on firefox 2 Rated 1 out of 5 stars

make it work with firefox 3.6