Fixed in 1.6.1 Rated 5 out of 5 stars

1.6 was automatically bumped by Mozilla, but was not specifically intended to be used with 5.0+ therefore there were issues that were only found in specific cases. The noscript combination bug that was found and fixed in 1.6.1pre2 resolves the crashes in these circumstances, 1.6.1 is currently waiting for mozilla review.

This review is for a previous version of the add-on (1.6.1-signed).