Incompatible Firefox 22.0 Rated 1 out of 5 stars

I got a message that it wouldn't install because it is incompatible with Firefox 22.0.