Easily one of the best extensions Rated 5 out of 5 stars

I completely agree. I'm using 3.0 B5 right now and was disappointed I couldn't use one of my favorite extensions without either turning off security/compatibility checks or going back to 2.0. Imagine my surprise when I checked today. Thank you!!! I have a personal blog with extensions I like to use and check regularly for updates and would appreciate feedback: http://jerryfardons.blogspot.com

This review is for a previous version of the add-on (2.7.1).