Linkificator Version History

33 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 2.0.0 111.2 KB Works with Firefox 21.0 and later

  • New features
    • Support of the new Firefox UI (Australis). The Linkificator's widget behavior is strictly identical to native widgets on Australis UI.
      The new behavior of widgets requires to change the configuration options of the mouse: It is no longer possible to configure the left boution mouse because it is reserved for displaying the context menu.
    • It is now possible to linkify an ignored page (blacklisted or not whitelisted). For that purpose, action 'Include' can be used (keyboard shortcut or widget context menu entry).
      NOTA: 'Include' action concerns only the current URL. Default filtering rules will be applied as soon as the page changes.
  • Enhancements and bug fixes
    • Enhances widget behavior in multi-windows mode.
  • Limitations
    • During upgrade to this major new version from a previous one (1.*), mouse buttons customization will be lost.

Version 2.0.0pre2 109.4 KB Works with Firefox 21.0 and later

  • New features
    • It is now possible to linkify an ignored page (blacklisted or not whitelisted). For that purpose, action 'Include' can be used (keyboard shortcut or widget context menu entry).
      NOTA: 'Include' action concerns only the current URL. Default filtering rules will be applied as soon as the page changes.
  • Enhancements and bug fixes
    • Widget context menu is now decorated with icons (Australis specific).
  • Limitations
    • During upgrade to this major new version from a previous one (1.*), mouse buttons customization will be lost.

Version 1.6.3 84.5 KB Works with Firefox 21.0 and later

  • Enhancements and bug fixes
    • Enhances widget handling in multi-windows mode.
  • Limitations
    • Due to new add-on packaging, minimal version supported is now Firefox 21.

Version 2.0.0pre1 106.2 KB Works with Firefox 21.0 and later

  • New features
    • Support of new Firefox UI (Australis). The Linkificator's widget behavior is strictly identical to native widgets on Australis UI.
      The new behavior of widgets requires to change the configuration options of the mouse: It is no longer possible to configure the left boution mouse because it is reserved for displaying the context menu.
  • Enhancements and bug fixes
    • Enhances widget behavior in multi-windows mode.
  • Limitations
    • During upgrade to this major new version from a previous one, mouse buttons customization will be lost.
    • Due to new add-on packaging, minimal version supported is now Firefox 21.

Version 1.6.2 82.1 KB Works with Firefox 21.0 and later

  • Enhancements and bug fixes
    • Optimizes document processing.
  • Limitations
      Due to new add-on packaging, minimal version supported is now Firefox 21.

Version 1.6.1 82.0 KB Works with Firefox 21.0 and later

  • Enhancements and bug fixes
    • It is now possible to deactivate automatic processing of dynamic changes (see 'Advanced settins', 'Links' tab).
    • Optimizes automatic processing to avoid potential lags.
  • Limitations
      Due to new add-on packaging, minimal version supported is now Firefox 21.

Version 1.6.1pre1 82.0 KB Works with Firefox 21.0 and later

  • Enhancements and bug fixes
    • It is now possible to deactivate automatic processing of dynamic changes (see 'Advanced settins', 'Links' tab).
    • Optimizes automatic processing to avoid potential lags.
  • Limitations
      Due to new add-on packaging, minimal version supported is now Firefox 21.

Version 1.6.0 81.5 KB Works with Firefox 21.0 and later

  • New features
    • The dynamic changes of current page are now detected and automatically processed.
  • Limitations
      Due to new add-on packaging, minimal version supported is now Firefox 21.

Version 1.5.3 287.3 KB Works with Firefox 13.0 and later

  • Enhancements and bug fixes
    • Fix erroneous handling of inline elements.
  • Limitations
    • Per window private browsing mode on Firefox 20 is not compatible with SDK panels feature. This feature is used by Linkificator for context menu.
      So, on Firefox 20, Linkificator context menu is deactivated. It is strongly recommended to upgrade to Firefox 21 and above to have a fully operational Linkificator.

Version 1.5.2 287.2 KB Works with Firefox 13.0 and later

  • Enhancements and bug fixes
    • By default, to reduce even more the false positives, the URLs containing only the authority (i.e. host:port) are no longer linkified, even if they contain a valid top level domain.
      The option 'Advanced Options->Links->Linkify URL containing the alone authority' enables to activate this treatment.
    • Enhances matching of URIs.
    • Speed-up processing when Top Level Domains are used.
  • Limitations
    • Per window private browsing mode on Firefox 20 is not compatible with SDK panels feature. This feature is used by Linkificator for context menu.
      So, on Firefox 20, Linkificator context menu is deactivated. It is strongly recommended to upgrade to Firefox 21 and above to have a fully operational Linkificator.

Version 1.5.1 286.5 KB Works with Firefox 13.0 and later

  • Enhancements and bug fixes
    • Enhances identification of start of URIs.
    • Enhances Top Level Domain matching.
  • Limitations
    • Per window private browsing mode on Firefox 20 is not compatible with SDK panels feature. This feature is used by Linkificator for context menu.
      So, on Firefox 20, Linkificator context menu is deactivated. It is strongly recommended to upgrade to Firefox 21 and above to have a fully operational Linkificator.

Version 1.5.0 286.3 KB Works with Firefox 13.0 and later

  • New features
    • To reduce false positives, URI are now recognized only if the domain part is terminated with a known top level domain.
      It is possible to de-activate this mode (and so, reverting to the behavior of the previous version) through 'Advanced settings', tab 'Links'.
  • Limitations
    • Per window private browsing mode on Firefox 20 is not compatible with SDK panels feature. This feature is used by Linkificator for context menu.
      So, on Firefox 20, Linkificator context menu is deactivated. It is strongly recommended to upgrade to Firefox 21 and above to have a fully operational Linkificator.

Version 1.4.2 281.5 KB Works with Firefox 13.0 and later

  • Enhancements and bug fixes
    • Speeds up the processing of inline tags to reduce drastically the potential freezes of Firefox
    • For a better compatibility with 'Pale Moon' browser, changes slightly the checking of version of Firefox to disable the panel on version 20
  • Limitations
    • Per window private browsing mode on Firefox 20 is not compatible with SDK panels feature. This feature is used by Linkificator for context menu.
      So, on Firefox 20, Linkificator context menu is deactivated. It is strongly recommended to upgrade to Firefox 21 and above to have a fully operational Linkificator

Version 1.4.1 280.8 KB Works with Firefox 13.0 and later

  • Enhancements and bug fixes
    • Enhance page history navigation handling (Back/Forward buttons)
  • Limitations
    • Per window private browsing mode on Firefox 20 is not compatible with SDK panels feature. This feature is used by Linkificator for context menu.
      So, on Firefox 20, Linkificator context menu is deactivated. It is strongly recommended to upgrade to Firefox 21 and above to have a fully operational Linkificator

Version 1.4.0 281.9 KB Works with Firefox 13.0 and later

  • New features
    • Left click is now configurable. As a result, menu can now be assigned to any mouse button.
      By default, for compatibility purpose, menu display is binded to left click
  • Enhancements and bug fixes
    • Per window private browsing mode is now fully supported but have some restrictions on Firefox 20 due to SDK limitations specifically on this version
  • Limitations
    • Per window private browsing mode on Firefox 20 is not compatible with SDK panels feature. This feature is used by Linkificator for context menu.
      So, on Firefox 20, Linkificator context menu is deactivated. It is strongly recommended to upgrade to Firefox 21 and above to have a fully operational Linkificator

Version 1.3.0 278.9 KB Works with Firefox 13.0 and later

  • New features
    • Page context menu integration: it is possible to update links through page context menu (customizable)
    • Middle click on Widget is now configurable. No action is binded by default
  • Enhancements and bug fixes
    • Change behavior of disabled state : linkificator actions are now reverted when Linkificator is disabled
    • Fix erroneous handling of status tooltip
  • Limitations
    • Per window private browsing mode (Firefox 20+) is not supported due to an Add-on SDK bug (see 816257).
      The support will be added as soon as SDK bug is fixed (planned for SDK 1.15 version)

Version 1.2.0 264.3 KB Works with Firefox 13.0 and later

  • New features
    • Possibility to toggle processing of the current page.
      This action can be launched through widget menu (Exclude/Include) or the hot key control-shift-x (customizable)
  • Enhancements and bug fixes
    • Enhance anchor handling when inline elements are involved
    • Add tag <wbr> to inline elements

Version 1.1.1 262.3 KB Works with Firefox 13.0 and later

  • New features
    • Possibility to update the current page without reloading it.
      This action can be launched by a right click on the Linkificator widget or through the hot key control-shift-u (customizable)
    • Left click on the widget now display a menu for an easy access to the most common operations as well as the options page
    • An action can be directly executed with a right click on the widget. This action is customizable (see Options)
  • Enhancements and bug fixes
    • Fix custom rule checkbox handling on Mac OS

Version 1.0.3 256.1 KB Works with Firefox 13.0 and later

Enhancements and bug fixes
  • Enable custom rules edition on Mac OS
  • Enhance statistics handling
  • Fix erroneous inline elements processing

Version 1.0.2 241.4 KB Works with Firefox 13.0 and later

Enhancements and bug fixes
  • Enhance URLs parsing
  • Reduce resources consumption and potential UI freezes

Version 1.0.1 241.3 KB Works with Firefox 13.0 and later

This version add the following enhancements and bug fixes:
  • Tag <span> is now handled has an inline element
  • Enhance localization messages

Version 1.0.0 241.0 KB Works with Firefox 13.0 and later

This version add the following new features and bug fixes:
  • New features
    • Inline elements, like <big> or <strong>, are now recognized and correctly handled during URLs parsing
    • Existing pages are now automatically parsed when add-on is installed or re-enabled. It is no longer required to manually reload the page
  • Enhancements and bug fixes
    • Multi-frames documents are now correctly handled in all cases
    • plain text documents are now recognized and parsed

Version 1.0.0pre3 241.1 KB Works with Firefox 13.0 and later

  • New features
    • Inline elements, like <big> or <strong>, are now recognized and correctly handled during URLs parsing
    • Existing pages are now automatically parsed when add-on is installed or re-enabled. It is no longer required to manually reload the page
  • Enhancements and bug fixes
    • Multi-frames documents are now correctly handled in all cases
    • plain text documents are now recognized and parsed

Version 1.0.0pre2 240.9 KB Works with Firefox 13.0 and later

  • New features
    • Inline elements, like <big> or <strong>, are now recognized and correctly handled during URLs parsing
    • Existing pages are now automatically parsed when add-on is installed or re-enabled. It is no longer required to manually reload the page
  • Enhancements and bug fixes
    • Multi-frames documents are now correctly handled in all cases
    • plain text documents are now recognized and parsed

Version 1.0.0pre1 217.3 KB Works with Firefox 13.0 and later

This version add the support of "inline" tags inside URLs. For example an URL including a part in bold or italic will be correctly parsed and handled.

Version 0.9.2 215.7 KB Works with Firefox 13.0 and later

This version add the following new features and bug fixes:
  • Support of custom rules. It is now possible to re-ordering rules by drag and drop.
  • multi-frames documents are now correctly handled.

Remarks
  • By default, Custom Rules are not active. To enable them, have a look at "Advanced settings", tab "Links".
  • It is possible to enabling/disabling each custom rule individually. For that purpose, in the Tab "Custom Rules", use the check-box located at the left of each rule

Version 0.9.1 214.0 KB Works with Firefox 13.0 and later

This version add the following new features and bug fixes:
  • Enhance preferences management
  • Enhance about: protocol handling
  • Support of custom rules. It is now possible to define your own rules to generate ad-hoc URLs. As an example, is included the handling of NBN (National Bibliography Number).
  • Text nodes not displayed are no longer proceeded

Remarks
  • By default, Custom Rules are not active. To enable them, have a look at "Advanced settings", tab "Links".
  • It is possible to enabling/disabling each custom rule individually. For that purpose, in the Tab "Custom Rules", use the check-box located at the left of each rule

Version 0.8.1 199.7 KB Works with Firefox 13.0 and later

Fix erroneous management of while/black lists

Version 0.8.0 199.7 KB Works with Firefox 13.0 and later

This version add the following features:
  • Support of Firefox Sync service. It enables sharing of settings between platforms. This feature is deactivated by default. See Linkificator options to activate it.
  • Full support of about: protocol. For security reason, the support is deactivated by default. It could be activated in the 'Advanced Settings', 'Links' tab
  • e-mail url parsing could now be deactivated if needed. see 'Advanced Settings', 'Links' tab.

Version 0.6.4 197.6 KB Works with Firefox 13.0 and later

Update for Add-on SDK 1.9 support