please please :| Rated 5 out of 5 stars

Please, update for Firefox 6! I use FF 3.6 just because this addon. :|