Rated 5 out of 5 stars

Everything is perfect for me. FF 3.5.11 and WinXP Pro SP2. Thanks FigaroSwe for this nice extension.

This review is for a previous version of the add-on (2.2.2.2).