Compatibility Issues Rated 3 out of 5 stars

I totally agree with DJM54. I depend on Lightning as part of my office productivity toolkit. I've lived with the Thunderbird Beta channel for some time, but each time an update breaks Lightning, I waste a great deal of time fixing the mess. I have to hunt for the list of version compatibilities (you'd think by now I'd have it bookmarked :)....). If I find it and I can locates the appropriate Lightning version, great. If not, like this time, I drop Thunderbird back a revision and get on the release channel

I really like the Lightning add-on but can't afford the time to keep fixing this issue. I won't be going back to the beta channel any time soon.

This review is for a previous version of the add-on (1.4).