Rated 5 out of 5 stars

I have updated this to work with Firefox 3.6.*. You can download the update here:
http://drop.io/mffld121/asset/library-detector-1-0-2-1-fx-xpi

Make sure you uninstall any old versions first, then use Firefox to navigate to where you saved the file. It should install with no issues.

-KPthunder

This review is for a previous version of the add-on (1.0.2).