Rated 5 out of 5 stars

if you have a liberty reserve account, this is a very helpful tool to prevent a scam from a fake site, is good also that lr always thinks in the safety of their customer that`s way they are my favorite payment processor

This review is for a previous version of the add-on (1.41). 

Rated 5 out of 5 stars

if you have a liberty reserve account, this is a very helpful tool to prevent a scam from a fake site, is good also that lr always thinks in the safety of their customer that`s way they are my favorite payment processor

This review is for a previous version of the add-on (1.41). 

Cool guard Rated 4 out of 5 stars

I have heard a lot about Liberty Guard and now a days i am getting lots of phishing mails.

Since i am using liberty reserve now and i am concerned about my money there so i have just installed liberty guard to protect my money from those threats.

Now i am also a user of liberty guard. :)

This review is for a previous version of the add-on (1.41). 

Avoid Scam Rated 5 out of 5 stars

LibertyGuard is a very useful add-on, especially for the people who uses the Libertyreserve account as their main payment processor. When you make a transaction online, you must avoid the fake sites, otherwise you will loose all the money and your account too. If you install this add-on in your Firefox browser, It will indicate you the actual libertyreserve site with a green color blinking text at the bottom of the screen. If it is not blinking, you must not enter your account details for any transaction. When you pay money in some sites via LR, they redirect you to libertyreserve sites, that time this add-on will help you a lot. This add-on must be in your browser if you use Libertyreserve.

This review is for a previous version of the add-on (1.41). 

Best Plugin so far for E-currencies. Rated 5 out of 5 stars

This Plugin is the One of the best Plugin so far for E-currency Security ... I have been Scammed so many times by logging in from fake websites which claimed that they are the original Liberty Reserve Website and after I login they steal away all my money from my account ... with this plugin you can easily defeat all those scamming websites and if the icon in the lower side of firefox is not blinking when you are on original LR Website then the site is the fake website and you should leave that website at once. I gives this plugin 10/10 score.

This review is for a previous version of the add-on (1.41). 

Rated 5 out of 5 stars

I have google toolbar, netcraft toolbar and now liberty guard toolbar - all protecting me against hackers. From my two week test libertyguard was the first to detect fake libertyreserve websites. Google and netcarft are too slow because they monitor thousands of websites (99% of which I never heard of). I use libertyreserve and libertyguard does 100% what I need it to do (and it does it pretty fast).

I never click on links in emails, but extra security won't hurt.

This review is for a previous version of the add-on (1.32). 

Rated 5 out of 5 stars

A few weeks ago hackers stole my password. My friend later found out that they sent me a link to a fkae liberty website. I talked to liberty support and they said that this addon is already blocking that fake website!! My friend tested this addon with that fake website and it DID block it!!!!! Too bad I didn't know about it before I lost my money. Does this addon work on my internet explorer too or should I use firefox? Thank you liberty.

This review is for a previous version of the add-on (1.32). 

Finally! Rated 5 out of 5 stars

I have been sending liberty reserve links to phishing websites for the last 6 months. Finally they did something to protect us from these @#@%^%$# hackers.
btw, where do I report the phishing websites? or is it still by email?

This review is for a previous version of the add-on (1.31). 

Rated 5 out of 5 stars

Excellent, a great improvement in the security field, to prevent users against fake websites.
Protecting our money and personal information.
thank you, Liberty Reserve!

This review is for a previous version of the add-on (1.31).