"Bad new update" from loxlox on April 7, 2012 Rated 2 out of 5 stars

Hallo,
loxlox has my full support: I don't like the new icons too. I used the theme a very long time...
By the way it is not possible to use the old version, it ist not compatible with Firefox 11 (although it was until yesterday)!!! Why?

This review is for a previous version of the add-on (2.0.0). 

Well, some prefer the new look and some the old.
The older theme (1.3.7) is compatible up to version 14.0a1.
It looks like a bug on AMO. Since the theme's compatibility was updated through AMO.

Anyway, there's always a workaround:
Type about:config into the address bar, and then after clicking through the warning, you’ll want to right-click in the list and choose New –> Boolean from the menu.

Now we’ll be prompted to enter the preference name. This is where you need to pay attention to the exact version you are using, because the preference has to be set for the exact version of Firefox you are using.

copy and paste this text: extensions.checkCompatibility.11.0

Make sure it's set on: False

You can do it also for version 12.0 etc.