Rated 5 out of 5 stars

please find a new file here.
Your old version 2.2 is highly compatible with firefox 4.
Here is the file http://goo.gl/jCidB

This review is for a previous version of the add-on (3.0t3.1-signed.1-signed).  This user has a previous review of this add-on.