Still dose not support Firefox 57+ Rated 2 out of 5 stars

Currently using the Nightly version of Firefox (58), but Lastpass still dose not even support version 57 yet. Because of this I have switched to using a extension called "bitwarden" that works perfectly. I actually don't miss Lastpass at all like I thought I would. Bitwarden works just as well and it was easy to import all of my usernames and passwords from Lastpass into Bitwarden.

When Lastpass dose support the newer versions of Firefox I'll probably go back just because its what I use on my phone as well, but until then I highly suggest bitwarden for anyone looking for a alternative to hold them over.