Doesn't Work With FF 57 Rated 1 out of 5 stars

I can't remember my sign ins and I'm too lazy to go to the site for it. Make it compatible you had months to do so. I pay good money for this.