Rated 1 out of 5 stars

No support for Firefox v57. What a shit company. If you cant support new browser versions, how can we expect you to proactively fix bugs and exploits and keep our information secure?

This review is for a previous version of the add-on (4.1.54).