I like LP, but FF sux Rated 4 out of 5 stars

Here is another reason why FF sux. With PaleMoon 24.2 (a BETTER version of FF), I can use LastPass 3.0 but with Firefox 25 and/or 26 I cannot, I have to use LastPass 2.0.

I really like LastPass but I wish that FF would get their act together and instead of releasing a new version every week, they take more time to correct bugs. Why are they releasing another version version of FF this week if last week's version has more bugs that a wasp's nest?

And a reply to a previous comment from Mr. LastPass Developer, I already tried installing LP 3.0 from the LP website onto FF 26 then FF 25, and your website reported both times:"The addon could not be downloaded because of a connection failure on lastpass.com." Therefore, as a final option I had to install LP 2.0 on FF 25.

This review is for a previous version of the add-on (2.0.20).