Rated 1 out of 5 stars

NO WAY! a NEW Firefox (26) and LastPass isn't compatible. I got a mozilla account just to tell you it's bogus. Please make it compatible, some people live by this addon. Like ME. Please.

This review is for a previous version of the add-on (2.0.20.1-signed). 

LastPass Supports FF26

Hello,

Apologies for the inconvenience, LastPass is fully compatible with FF26 but the update must currently be downloaded from our site: https://lastpass.com/download - we hope to have it published on AMO in the near future, once we make it through their approval process.