Rated 5 out of 5 stars

For compatibility with the latest versions of Firefox you'll want the latest version of Lastpass.

To get the latest version of Lastpass, go to the Lastpass.com web site and click on "full list of downloads for your platform". (The 64-bit versions include the 32-bit versions.)

This review is for a previous version of the add-on (2.0.0).