Rated 5 out of 5 stars

LastPass 2.0.0 is incompatible with Firefox 17.0.1.

Lastpass 20.0a1 (https://lastpass.com/lp.php) works great, thanks :)

This review is for a previous version of the add-on (2.0.0). 

LastPass works with all Firefox versions

We should work with the latest (20.0a1) version of Firefox. Please download from https://lastpass.com/lp.php.

Thanks