compatible error Rated 5 out of 5 stars

Hello to downloads of lastpass comes with me that it is not compatible with firefox mobile is 14 ... what can be wrong

This review is for a previous version of the add-on (1.90.6).