LastPass after 1.44 is Broken Rated 5 out of 5 stars
I still recommend using LastPass just don't upgrade past 1.44 until they fix the bugs. If your running Firefox 3.5 and up you will need to add these about:config tweaks.
[extensions.checkCompatibility = False]
[extensions.checkUpdateSecurity = False]
You can get LastPass 1.44 here
More than 99% of our users are using versions greater than 1.50 DO NOT USE 1.44, it has hundreds of bugs we've fixed! -- please email your problem to firstname.lastname@example.org