Out of Date Rated 1 out of 5 stars

Not compatible with the current version of Thunderbird :-(