No Firefox 5.0 support? Rated 5 out of 5 stars

I LOVE this addon...can't imagine surfing without it but we need Firefox 5.0 support. Please update! :)

This review is for a previous version of the add-on (0.4.4).