Actually NOT compatible with 3.6.3 Rated 3 out of 5 stars

Currently using Firefox 3.6.3 and had a failed install of Jureeka 2.3 due to incompatibility, although from the search result list it shows up as working with my FF version. What a shame, I was excited about this for a minute. :(

This review is for a previous version of the add-on (2.3.1-signed).