Rated 5 out of 5 stars

As Behal said, 1.4 is rejected by Firefox 3.5.7.
After looking at the install.rdf in the .xpi file, I see why: the minVersion is set to 3.6!
If I change it to 3.0, it installs correctly. I hope it still works on 3.5-

This review is for a previous version of the add-on (1.4.1).